Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2024 - 16:00 CET
Scheduled
We will update our software with bug fixes.
Posted Nov 07, 2024 - 15:32 CET
This scheduled maintenance affected: Open Health Hub Viewer (Viewer application), Open Health Hub Manager (Manager application), Improve Mobile app (Auth server), Open Health Hub Designer (Auth server), and Improve Connected Health (Auth server).