Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2025 - 19:00 CEST
Scheduled
We will be carrying out planned maintenance on our databases to keep our services secure, stable, and up to date.
Type of Change: Possible customer impact (within maintenance window) Impact: During this maintenance, your instance will experience a brief drop in connectivity
Posted Sep 03, 2025 - 20:09 CEST
This scheduled maintenance affected: Frontend Services (Form Designer, Form Filler, Desktop Viewer, Manager application), Authentication Services (Auth server), Communication Services (Push services, Mail services), and Backend Services (Open Health Hub Platform, FHIR API, FHIR API sandbox, FHIR Viewer Backend services, Manager Backend).